[aspect-devel] Trilinos problems ( I guess )

Jonathan Perry-Houts jperryh2 at uoregon.edu
Fri Sep 11 14:58:59 PDT 2015

For me it's only been on the university's cluster. My workstation and
laptop have been just fine.

I finally solved it by moving to a newer compiler (I was using OpenMPI
1.6 built on GCC 4.7, and now I'm using OpenMPI 1.8 on GCC 4.9).

I think it's not a problem in ASPECT or deal.II because I went back
pretty far in the git history (like 150 commits back, in increments of
50) and they all failed with the same error. Deal.ii's step-32 worked
the whole time, but I don't think it uses the same preconditioner so
that's probably not a fair check that the problem wasn't in deal.ii.

Well, whatever. At least it seems to work here now. Sorry I didn't find
anything more diagnostic that might help solve this on your desktop,
Wolfgang. Keep us posted if you figure it out.


On 09/11/2015 06:54 AM, Wolfgang Bangerth wrote:
> On 09/11/2015 08:31 AM, Timo Heister wrote:
>> I haven't seen something like that before. The only thing I can think
>> of is testing what library is breaking things: start by going back in
>> time with ASPECT, then deal.II. Annoying.:(
> Actually -- I have seen this for the past few weeks as well. I already
> thought I was going crazy. It only happens on my workstations, not my
> laptop.
> I'll give it a try to bisect what may have caused that.
> Best
>  W.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 538 bytes
Desc: OpenPGP digital signature
URL: <http://lists.geodynamics.org/pipermail/aspect-devel/attachments/20150911/645d717b/attachment.sig>

More information about the Aspect-devel mailing list