[aspect-devel] Trilinos problems ( I guess )

Wolfgang Bangerth bangerth at tamu.edu
Mon Sep 14 11:46:55 PDT 2015

On 09/11/2015 04:58 PM, Jonathan Perry-Houts wrote:
> For me it's only been on the university's cluster. My workstation and
> laptop have been just fine.
> I finally solved it by moving to a newer compiler (I was using OpenMPI
> 1.6 built on GCC 4.7, and now I'm using OpenMPI 1.8 on GCC 4.9).
> I think it's not a problem in ASPECT or deal.II because I went back
> pretty far in the git history (like 150 commits back, in increments of
> 50) and they all failed with the same error. Deal.ii's step-32 worked
> the whole time, but I don't think it uses the same preconditioner so
> that's probably not a fair check that the problem wasn't in deal.ii.
> Well, whatever. At least it seems to work here now. Sorry I didn't find
> anything more diagnostic that might help solve this on your desktop,
> Wolfgang. Keep us posted if you figure it out.

I tried it just now by installing the current deal.II, then doing a
   'make clean; make'
in my aspect build directory and, to my great surprise, it works again for the 
first time in several weeks. I have no idea what changed. I also went back a 
few weeks in the deal.II history (where I'm sure it didn't work), compiled 
deal.II from back then, and it also works. I'm startled. I'm also relieved. I 
don't think there is much else I can do for now, other than hope that nobody 
else runs into this problem...


Wolfgang Bangerth               email:            bangerth at math.tamu.edu
                                 www: http://www.math.tamu.edu/~bangerth/

More information about the Aspect-devel mailing list